Resolved- Unable to Dispatch Rentals
Incident Report for U-Haul System
Resolved
Resolved - A fix has been provided, and you may continue with business.

If you are still experiencing an issue, please contact POS support at VOIP ext 606911, 800-223-6217 or via live chat by selecting the life preserver located in the lower left of the ESL.
-------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Nov 19, 2024 - 17:34 MST
Update
Resolved - A fix has been provided, and you may continue with business.

If you are still experiencing an issue, please contact POS support at VOIP ext 606911, 800-223-6217 or via live chat by selecting the life preserver located in the lower left of the ESL.
--------------------------------------------------------------------------------------------------
Posted Nov 19, 2024 - 17:31 MST
Monitoring
Workaround: Dispatch using back up POS:
backuppos.uhaul.net

Reminder:
Centers- Login With Your SMID, Last name and entity #
Dealers- Login with your Dealer login and your Entity #

For further assistance can contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
------------------------------------------------------------------------------------------------------------------------------------------
Posted Nov 19, 2024 - 17:19 MST
Investigating
Workaround: Dispatch using back up POS:
backuppos.uhaul.net

Reminder:
Centers- Login With Your SMID, Last name and entity #
Dealers- Login with your Dealer login and your Entity #

For further assistance can contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Nov 19, 2024 - 16:26 MST
This incident affected: Point of Sale (POS) and Rates and Distribution (Web AMT).